Naming Conventions colors.xml Android

It is one thing to come up with intuitive naming for String keys but its totally another to manage and organise your colors in an Android project.
The Problem :
Your colors.xml will initially have the primary, primaryDark and accent by default, based on your theme pallette.
Later you would add few colors with their proper name.
ex: white, black, red etc,.
But before you could realise, you would have started adding the location of the color, as the key, rather than the color itself.
ex: login_bg_color

This is a very common scenario in many Android projects. Developers tend to ignore these small details, but these count a lot when you work on a Strong UI focused project.

There are many naming conventions to follow. Android Material design suggests to use color_shade format but its not completely unique and can be easily referenced. I wouldn’t be going deep inside good practices from Material design etc,.
Rather, I am suggesting a very simple approach.
Best Practice:
Advantages of the solution being proposed :
- Prevent duplications of same colors with different names
- Color names will be unique and self-descriptive
Naming convention :
You can use websites to get the name of your color so it remains unique.
Ex:

The color name produced by tools like these might be non-intuitive for most of us but that shouldn’t be an issue because ideally we would not be using all the colors everywhere inside the application.

There are scenarios where two colors might produce the same name. It would mean that you need to rethink your color usage, or create a color xml with alpha to differentiate between the two
If you feel the need to make your colors more intuitive, then adding the dominant color as prefix should help a bit.
ex: shamrock -> green_shamrock

You can use sites like https://www.color-blindness.com/color-name-hue/ to get the hue color
Alpha:
You run into situations where you colors have varied alpha. You easily get tempted to add suffix like _10, _80 to your existing colors. This is a bad approach.
Follow the advice of Nick Butcher and Chris Banes and create a SingleItem ColorStateList for similar situations.